Eric W. Biederman
f8a68e752b
Revert "ipv4: arp announce, arp_proxy and windows ip conflict verification"
...
This reverts commit 73ce7b01b4 .
After discovering that we don't listen to gratuitious arps in 2.6.30
I tracked the failure down to this commit.
The patch makes absolutely no sense. RFC2131 RFC3927 and RFC5227.
are all in agreement that an arp request with sip == 0 should be used
for the probe (to prevent learning) and an arp request with sip == tip
should be used for the gratitous announcement that people can learn
from.
It appears the author of the broken patch got those two cases confused
and modified the code to drop all gratuitous arp traffic. Ouch!
Cc: stable@kernel.org
Signed-off-by: Eric W. Biederman <ebiederm@aristanetworks.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
2009-06-30 19:47:08 -07:00
..
9p
virtio: find_vqs/del_vqs virtio operations
2009-06-12 22:16:36 +09:30
802
net: remove COMPAT_NET_DEV_OPS
2009-05-25 01:53:53 -07:00
8021q
8021q: Vlan driver should use rcu_barrier() on unload instead of syncronize_net()
2009-06-10 01:11:22 -07:00
appletalk
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
atm
atm: sk_wmem_alloc initial value is one
2009-06-18 00:29:12 -07:00
ax25
net: Move rx skb_orphan call to where needed
2009-06-23 16:36:25 -07:00
bluetooth
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
bridge
bridge: Use rcu_barrier() instead of syncronize_net() on unload.
2009-06-26 13:51:32 -07:00
can
can: af_can.c use rcu_barrier() on module unload.
2009-06-10 01:11:24 -07:00
core
gro: Flush GRO packets in napi_disable_pending path
2009-06-26 19:27:04 -07:00
dcb
dccp
ipv6: Use correct data types for ICMPv6 type and code
2009-06-23 04:31:07 -07:00
decnet
decnet: Use rcu_barrier() on module unload.
2009-06-26 13:51:27 -07:00
dsa
net: convert unicast addr list
2009-05-29 22:12:32 -07:00
econet
net: sk_wmem_alloc has initial value of one, not zero
2009-06-17 04:31:25 -07:00
ethernet
net: remove COMPAT_NET_DEV_OPS
2009-05-25 01:53:53 -07:00
ieee802154
nl802154: add module license and description
2009-06-29 18:20:28 +04:00
ipv4
Revert "ipv4: arp announce, arp_proxy and windows ip conflict verification"
2009-06-30 19:47:08 -07:00
ipv6
inet: Call skb_orphan before tproxy activates
2009-06-26 19:22:37 -07:00
ipx
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
irda
net: Move rx skb_orphan call to where needed
2009-06-23 16:36:25 -07:00
iucv
Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next-2.6
2009-06-22 11:57:09 -07:00
key
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
lapb
llc
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
mac80211
mac80211: Use rcu_barrier() on unload.
2009-06-26 13:51:36 -07:00
netfilter
netfilter: xtables: conntrack match revision 2
2009-06-29 14:31:46 +02:00
netlabel
netlabel: Use genl_register_family_with_ops()
2009-05-21 16:50:24 -07:00
netlink
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
netrom
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
packet
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
phonet
Phonet: generate Netlink RTM_DELADDR when destroying a device
2009-06-25 02:58:16 -07:00
rds
Merge branch 'master' of master.kernel.org:/pub/scm/linux/kernel/git/davem/net-2.6
2009-05-18 21:08:20 -07:00
rfkill
rfkill: export persistent attribute in sysfs
2009-06-19 11:50:18 -04:00
rose
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
rxrpc
RxRPC: Don't attempt to reuse aborted connections
2009-06-16 21:20:14 -07:00
sched
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
sctp
sctp: xmit sctp packet always return no route error
2009-06-29 19:41:53 -07:00
sunrpc
sunrpc: Use rcu_barrier() on unload.
2009-06-26 13:51:34 -07:00
tipc
tipc: Use genl_register_family_with_ops()
2009-05-21 16:50:23 -07:00
unix
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
wanrouter
wimax
wimax: fix warning caused by not checking retval of rfkill_set_hw_state()
2009-06-11 11:12:48 -07:00
wireless
cfg80211: validate station settings
2009-06-19 11:50:24 -04:00
x25
net: correct off-by-one write allocations reports
2009-06-18 00:29:12 -07:00
xfrm
xfrm: use xfrm_addr_cmp() instead of compare addresses directly
2009-06-29 19:41:46 -07:00
compat.c
Kconfig
net: add IEEE 802.15.4 socket family implementation
2009-06-09 05:25:32 -07:00
Makefile
net: add IEEE 802.15.4 socket family implementation
2009-06-09 05:25:32 -07:00
nonet.c
socket.c
sysctl_net.c
TUNABLE